This project is read-only.

Z-wave Driver Config

Jun 17, 2015 at 5:26 PM
Hello,
My aeon multisensor is acting up and I believe it has something to do with my App.config in Hub\Drivers\ZwaveZensys_4_55.  Could someone post their App.config file so I could cross check it with mine?  I can currently get temperature data from it, but it only sends every 4 minutes.  I would like to receive this data much more quickly.  
Thanks for the help
Jun 17, 2015 at 7:05 PM
Hi, I've messaged you the contents of the original app.config.
Thanks

Danny
Marked as answer by mrk997 on 6/17/2015 at 1:14 PM
Jun 17, 2015 at 11:06 PM

The “golden” App.config is appended below.

As for debugging your issue, try a couple of things:

- Check the behavior when the multi-sensor is plugged in using USB instead of batteries. We’ve seen cases where reporting behavior changes when the battery is low, independent of what is configured.

- If that test passes, remove and add the device. This exercise will try to reconfigure the device. Check the logs to see if device configuration failed.

Cheers.

----------

<?xml version="1.0" encoding="utf-8" ?>

<!-- most of configuration stuff is taken from http://www.pepper1.net/zwavedb/-->

<configuration>

<!-- This section should come before any others -->

<configSections>

<section name="deviceSettings"

type="HomeOS.Hub.Drivers.ZwaveZensys.Configuration.DeviceSettingsSection, HomeOS.Hub.Drivers.ZwaveZensys_4_55"/>

</configSections>

<appSettings>

<add key="HomeOSUpdateVersion" value="1.0.0.3" />

</appSettings>

<deviceSettings>

<device name="aeon multisensor">

<settings>

<setting name ="sensor report type on Get without instances" paramNum="01" level="01" value="00"/>

<setting name ="wake up 10 minutes when batteries are inserted" paramNum="02" level="01" value="01"/>

<setting name ="on time" paramNum="03" level="02" value="00 01"/>

<setting name ="enable motion sensor" paramNum="04" level="01" value="01"/>

<setting name ="send unsolicited reports periodically. Interval group 1" paramNum="101" level="04" value="00 00 00 225"/>

<setting name ="unsolicitate reports interval for timing groups 1" paramNum="111" level="04" value="00 00 00 60"/>

</settings>

<roles>

<role name=":sensormultilevel::temperaturesensor:"/>

<role name=":sensormultilevel::luminositysensor:"/>

<role name=":sensormultilevel::humiditysensor:"/>

</roles>

</device>

<device name="aeon smart energy switch">

<settings>

<setting name ="type of sensor report" paramNum="01" level="01" value="00"/>

<setting name ="notification on status change" paramNum="80" level="01" value="02"/>

<setting name ="report type in reporting group 1" paramNum="101" level="04" value="00 00 00 02"/>

<setting name ="send interval for reporting group 1" paramNum="111" level="04" value="00 00 00 60"/>

</settings>

<roles>

<role name=":sensormultilevel::powersensor:"/>

</roles>

</device>

<device name="aeon home energy meter">

<settings>

<setting name ="automated report only when power is changed" paramNum="03" level="01" value="00"/>

<setting name ="report type send in reporting group 1" paramNum="101" level="04" value="00 00 00 03"/>

<setting name ="send interval for reporting group 1" paramNum="111" level="04" value="00 00 00 60"/>

</settings>

<roles>

<role name=":sensormultilevel::powersensor:"/>

</roles>

</device>

</deviceSettings>

</configuration>