This project is read-only.

Some problems while reading "Getting_Started_with_Lab_of_Things.pdf"

Oct 17, 2013 at 2:50 AM
I'm interesting in HomeOS and have read "Getting_Started_with_Lab_of_Things.pdf" several times.
but there are still remain lots of problems while I step by step according to the "Getting_Started_with_Lab_of_Things.pdf".
The following problems are some of them:
  1. "_Pre-Setup
    Before deploying to a hub, you first need to enter your organization ID (OrgID) in
    Hub\output\configs\settings.xml._"(page 5)
    I can't found "Hub\output\configs\settings.xml.", should I set up the document in local disk or download it from website?
2."_From homeos2\Hub\output\binaries\platform\ run
HomeOS.hub.platform.exe -c ....\Configs\Config._"(P5)
can't found "homeos2"

3.I log into "http://localhost:51430/GuiWeb/AddLiveIdUser.html" wrote my name and account, click "add user", but it display some error:
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect

What am I supposed to do?
Oct 18, 2013 at 2:07 AM
  1. Did you build the solution first?
  2. homeos2 is the root of the source code.
  3. It looks like you installed the MSI. Try uninstall the MSI.
Then, download just the source code. To build the project:
  • Open core.sln and build the solution.
  • Open the command prompt as administrator
  • Then, in source\Hub\output run the command startplatform.bat
  • Once platform is running, go to http://localhost:51430/GuiWeb/index.html in the browser
caspar2013 wrote:
I'm interesting in HomeOS and have read "Getting_Started_with_Lab_of_Things.pdf" several times.
but there are still remain lots of problems while I step by step according to the "Getting_Started_with_Lab_of_Things.pdf".
The following problems are some of them:
  1. "_Pre-Setup
    Before deploying to a hub, you first need to enter your organization ID (OrgID) in
    Hub\output\configs\settings.xml._"(page 5)
    I can't found "Hub\output\configs\settings.xml.", should I set up the document in local disk or download it from website?
2."_From homeos2\Hub\output\binaries\platform\ run
HomeOS.hub.platform.exe -c ....\Configs\Config._"(P5)
can't found "homeos2"

3.I log into "http://localhost:51430/GuiWeb/AddLiveIdUser.html" wrote my name and account, click "add user", but it display some error:
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect

What am I supposed to do?
Oct 21, 2013 at 4:48 AM
Edited Oct 21, 2013 at 4:51 AM
Well, it's seem that I'm a novice and there are some knowledge that I must learn.
I just want to build a small HomeOS platform to test it for fun. And I wonder if I'm a normal users without any programming experience, thus I can't establish(use) the HomeOS?
In view of the problem last time, could you explain more specific?
<br/>
  1. It's easy to build a blank solution, but it has any relationship with settings.xml?
  2. I knew homeos2 is the root of the source code, is it going to build it by myself?
  3. I have uninstalled the MSI this time and open the command prompt as administrator. open the command startplatform.bat, but it may has some errors( it closed itself too quickly to see it clearly).( PS: What is the relationship between the two independent windows command prompt and startplatform.bat?)
I used to be a C language programming enthusiasts, and now I study HTML, XML, JavaScript, C#, English only by myself. I hope you could give me some suggestions.
...It may be beyond my ability?





dannyh206 wrote:
  1. Did you build the solution first?
  2. homeos2 is the root of the source code.
  3. It looks like you installed the MSI. Try uninstall the MSI.
Then, download just the source code. To build the project:
  • Open core.sln and build the solution.
  • Open the command prompt as administrator
  • Then, in source\Hub\output run the command startplatform.bat
  • Once platform is running, go to http://localhost:51430/GuiWeb/index.html in the browser
caspar2013 wrote:
I'm interesting in HomeOS and have read "Getting_Started_with_Lab_of_Things.pdf" several times.
but there are still remain lots of problems while I step by step according to the "Getting_Started_with_Lab_of_Things.pdf".
The following problems are some of them:
  1. "_Pre-Setup
    Before deploying to a hub, you first need to enter your organization ID (OrgID) in
    Hub\output\configs\settings.xml._"(page 5)
    I can't found "Hub\output\configs\settings.xml.", should I set up the document in local disk or download it from website?
2."_From homeos2\Hub\output\binaries\platform\ run
HomeOS.hub.platform.exe -c ....\Configs\Config._"(P5)
can't found "homeos2"

3.I log into "http://localhost:51430/GuiWeb/AddLiveIdUser.html" wrote my name and account, click "add user", but it display some error:
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect

What am I supposed to do?
Oct 31, 2013 at 5:04 AM
Lab of Things is a platform intended for researchers interested in connected devices and technical DIY users who are interested in home automatio. You can run HomeOS without programming, but what you can do is limited. If you don't want to build the solution at all, you can down load the output of the solution here:
http://repository.lab-of-things.net/download/output.zip (the run startplatform.bat)

About your questions:
  1. Settings.xml is where all the settings for the home hub are. The file is explained in this doc LoT_configuration.pdf
  2. To build the solution, you go to \homeos2\Hub\ and load core.sln to build it.
  3. You have to run startplatform.bat from the output directory. Make sure you open the command line prompt using the "Run as Administrator" option
caspar2013 wrote:
Well, it's seem that I'm a novice and there are some knowledge that I must learn.
I just want to build a small HomeOS platform to test it for fun. And I wonder if I'm a normal users without any programming experience, thus I can't establish(use) the HomeOS?
In view of the problem last time, could you explain more specific?
<br/>
  1. It's easy to build a blank solution, but it has any relationship with settings.xml?
  2. I knew homeos2 is the root of the source code, is it going to build it by myself?
  3. I have uninstalled the MSI this time and open the command prompt as administrator. open the command startplatform.bat, but it may has some errors( it closed itself too quickly to see it clearly).( PS: What is the relationship between the two independent windows command prompt and startplatform.bat?)
I used to be a C language programming enthusiasts, and now I study HTML, XML, JavaScript, C#, English only by myself. I hope you could give me some suggestions.
...It may be beyond my ability?





dannyh206 wrote:
  1. Did you build the solution first?
  2. homeos2 is the root of the source code.
  3. It looks like you installed the MSI. Try uninstall the MSI.
Then, download just the source code. To build the project:
  • Open core.sln and build the solution.
  • Open the command prompt as administrator
  • Then, in source\Hub\output run the command startplatform.bat
  • Once platform is running, go to http://localhost:51430/GuiWeb/index.html in the browser
caspar2013 wrote:
I'm interesting in HomeOS and have read "Getting_Started_with_Lab_of_Things.pdf" several times.
but there are still remain lots of problems while I step by step according to the "Getting_Started_with_Lab_of_Things.pdf".
The following problems are some of them:
  1. "_Pre-Setup
    Before deploying to a hub, you first need to enter your organization ID (OrgID) in
    Hub\output\configs\settings.xml._"(page 5)
    I can't found "Hub\output\configs\settings.xml.", should I set up the document in local disk or download it from website?
2."_From homeos2\Hub\output\binaries\platform\ run
HomeOS.hub.platform.exe -c ....\Configs\Config._"(P5)
can't found "homeos2"

3.I log into "http://localhost:51430/GuiWeb/AddLiveIdUser.html" wrote my name and account, click "add user", but it display some error:
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect
Did not find the file: D:\Program Files\LabOfThings\Hub\output\binaries\Platform\DashboardWeb\auth\redirect

What am I supposed to do?