Problem with Azure 2.3 dependency

Nov 24, 2014 at 2:02 PM
Hi all,

I am trying to get LoT up and running here at my research lab to do some tests, however I am having trouble with the Azure dependency. It seems that it is no longer possible to download Azure 2.3 from the Azure website. I have tried here:

http://azure.microsoft.com/en-us/downloads/archive-net-downloads/

specifically the 2.3 version for Visual Studio 2012:

http://go.microsoft.com/fwlink/p/?linkid=394365&clcid=0x409

If I go for the manual installer options, I get the option to download a bunch of installers and I have no idea which one I need to use.

I also tried the links provided in "Getting Started with Lab of Things" documentation section but the Web Platform installer gives me the same error that it can't find the requested software.

Any ideas how to solve this?

Thanks,
Federico Domínguez
Coordinator
Nov 24, 2014 at 3:27 PM
Hi Federico,

Thanks for bringing this to our attention. The web platform installer links you found on the Getting Started page must have changed since the page was last updated.
I'd follow the recommendation on this page, instead of manually downloading the files listed on the page, use the automated one-click install provided by the Web Platform Installer:
VS 2013
VS 2012

I'll update the documentation. Thanks again for reporting the issue.
Danny
Coordinator
Nov 24, 2014 at 3:29 PM
dannyh206 wrote:
Hi Federico,

Thanks for bringing this to our attention. The web platform installer links you found on the Getting Started page must have changed since the page was last updated.
I'd follow the recommendation on this page, instead of manually downloading the files listed on the page, use the automated one-click install provided by the Web Platform Installer:
VS 2013
VS 2012

I'll update the documentation. Thanks again for reporting the issue.
Danny
Hmm, I see that the 1-click installers are pointing to 2.5 versions of the SDK. Let me find out how to get 2.3 and earlier versions.
Coordinator
Nov 24, 2014 at 7:19 PM
dannyh206 wrote:
dannyh206 wrote:
Hi Federico,

Thanks for bringing this to our attention. The web platform installer links you found on the Getting Started page must have changed since the page was last updated.
I'd follow the recommendation on this page, instead of manually downloading the files listed on the page, use the automated one-click install provided by the Web Platform Installer:
VS 2013
VS 2012

I'll update the documentation. Thanks again for reporting the issue.
Danny
Hmm, I see that the 1-click installers are pointing to 2.5 versions of the SDK. Let me find out how to get 2.3 and earlier versions.
Looks like the one-click installers for 2.3 are no longer available. This is what you can do. On the download page for version 2.3, download and install the following :
[choose the options that match your os]
  • WindowsAzureLibsForNet-x64.msi or WindowsAzureLibsForNet-x86.msi
  • WindowsAzureAuthoringTools-x64.msi or WindowsAzureAuthoringTools-x86.msi
These two should work for both VS2012 and VS2013

Note you will still need the Microsoft Sync Framework 2.1 Redistributable Package (Get the X86 version for both Synchronization and ProviderServices, regardless of your OS architecture )