Need help getting started

Sep 7, 2014 at 8:48 AM
Hi,

I apologise if this is an issue with me being a noob.

I am trying to install LoT and get it started. I have followed the process to ensure all of the pre-requisites for LoT have been installed. However when I try to build the core solution, I get this error:

**
The Visual C++ project "SmartRecorder" is targeting ".NETFramework,Version=4.5", which is not installed on this machine. To proceed, select an option below.

[] Download the targeting pack for ".NETFramework,Version=v4.5". The project will not change
[] Do not load the project.
**

When I select the download option I am taken to a webpage for downloads for the .NET Framework ... I have installed everything from that page for .NET Framework 4.5.

At the same time I get an alert in Visual Studio which states:

**
The C# project "Contracts" is targeting ".NETFramework, Version=v4.5", which is not installed on this machine. To proceed, select an option below.

[] Change the target to .NET Framework 4.5. You can change back to ".NETFramework, Version=v4.5" at a later time
[] Download the targeting pack for ".NETFramework,Version=v4.5". The project will not change.
[] Do not load the project.
**

The first option "Change" is pre-selected. When I choose this option I get a large amount of errors in the rebuild. For example:

**
The reference assemblies for framework ".NETFramework,Version=v4.5" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of the reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intended.
**

I'm fairly certain I have everything that I need installed.

I'm not really sure where to go from here and am looking for some guidance.

Thanks!
Coordinator
Sep 7, 2014 at 3:01 PM
Hi,
Which version of the Visual Studio do you have? If you are using the 2013 version, you will be prompted to upgrade two C++ projects (WebCamLib and SmartRecorder). Check both projects to be upgraded to 2013 mode.

Let me know if the above is relevant to your issue.

Danny
Sep 7, 2014 at 8:51 PM
Hi Danny,

Thanks for your reply. Really appreciate that.

I am using VS2012 as I want to use Gadgeteer with the project.

Pete
Coordinator
Sep 11, 2014 at 8:57 PM
petewnr wrote:
Hi Danny,

Thanks for your reply. Really appreciate that.

I am using VS2012 as I want to use Gadgeteer with the project.

Pete
Just want to let the group know that in order to build the core.sln you need the Azure SDK version 2.3 or older (we tested as far back as 2.1), as some of the dependencies are no longer in 2.4 and newer versions. The prerequisites on the Getting Started page in the docs has been updated to be more specific about the versions of the Azure SDK. Thanks for bringing this to our attention, Pete.

Danny