This project is read-only.

Not able to get sensor data from Aeo multisensors

Aug 12, 2014 at 12:03 AM
I'm using ZWave driver to communicate with AeoTec's Multi-sensors. When I tried it out around one to two months ago, I was able to get the temperature, humidity, and luminosity data. However, when I tried it today, I could only get the motion sensor data. I am not sure if something goes wrong with the RoleSensorMultiLevel role.

I've tried to use ZWave PC Controller to issue BASIC_GET cmd to a multisensor, and it seemed to return multiple hex data, although I don't know how to interpret that. This probably means the sensor could still detect something, but there is something wrong with the driver or my Lab of things app.

I've tried multiple multi-sensors, and they all have the same problem, thus it's not the device's problem.

Thanks in advanced.
Aug 12, 2014 at 12:08 AM
When did you get the z-wave driver? Can you send me a private message? My ID is dannyh206

Aug 12, 2014 at 1:54 AM

We have experienced this behavior when the battery in the sensor starts running low. Can you try with new batteries or plugging the device into power?

Aug 16, 2014 at 8:44 PM
I figure out the problem. If I run the platform with a Zwave stick that already connects to the multisensors, the platform would automatically detect these nodes in the "Add Device" page. If I add these nodes directly, they would only detect motion. If I do a hard reset via ZWave Controller (remove all the nodes) and pair the nodes again, they would behave correctly.
Aug 19, 2014 at 2:00 AM
Thanks for this update. I haven't experienced that chain of events so it is good to have it documented here with the workaround. Thanks.

Sent from my Windows Phone