How do I help? Seeking to start developing for HomeOS

Jul 27, 2014 at 6:23 PM
Do you have a place with a How to Start page?
Coordinator
Jul 27, 2014 at 6:39 PM
Jul 27, 2014 at 8:59 PM
Yes, very excited about this new technology. Will be setting up dev env soon. What is a good video camera to get to get up and running quickly?

Sent from my Windows Phone

From: ratulm
Sent: 7/27/2014 11:39 AM
To: [email removed]
Subject: Re: How do I help? Seeking to start developing for HomeOS [labofthings:554349]

From: ratulm

Coordinator
Jul 27, 2014 at 10:33 PM

If you have a webcam (built-in or USB), that is the fastest way to get started with cameras. Otherwise, we also support Foscam IP cameras (e.g., http://foscam.us/foscam-fi8918w-wireless-ip-camera-11.html) and Axis cameras. We use the Foscams more in our internal testing.

Cheers.

Coordinator
Jul 28, 2014 at 7:33 PM
ratulm wrote:
Is https://labofthings.codeplex.com/documentation what you are looking for?
Hi,
Please check out the video tutorials on this page too: http://www.lab-of-things.com/getstarted.html
Jul 28, 2014 at 10:55 PM
Edited Jul 28, 2014 at 11:14 PM
Just did git clone on labofthings and have the files now.

I am running a dev laptop (powerful) running windows 8.1 with VS2012/VS2013. I would like to build targeting VS2013, Windows 8.1 on Laptop and Surface Pro 2. Would like to create a security app for the windows store for Surface and Phone.

Installed:
Windows 8.1
Visual C++/CLI and C#
.NET Framework 4.5.1
Windows Azure SDK (Windows Azure Storage Emulator - v3.2)
Microsoft Sync Framework 2.1 SDK (x64) ENU
Windows Driver Package - Silicon Laboratories (silabenm) Ports (3:19:2014) (x64)

Working on getting an OrgID.

I setup a trial Azure account last night. Created one web site. I am assuming it is targeting latest ASP.NET.
Jul 28, 2014 at 11:11 PM

Set up a Home Hub for Evaluation This section explains how to set up a Home Hub for evaluation.

Pre-Setup Before deploying to a hub, you first need to enter your organization ID (OrgID) in Hub\output\configs\settings.xml. To obtain an OrgID, email a request to Lab-of- [email removed]. The OrgID is used to associate your Home Hubs with your organization.

I would like to requrest an OrgID for AGMedia Group, which is the name of my company.

Rob

Jul 28, 2014 at 11:17 PM
I was robbed the other day so my first project is to create a security system for my home ;-) Hopefully soon!
Coordinator
Jul 28, 2014 at 11:17 PM
Hi Rob,
You are probably looking at an outdated pdf file which we included for a previous version of beta. Sorry for the confusion.

Please use these instructions to get started:
https://labofthings.codeplex.com/wikipage?title=Getting%20Started%20with%20Lab%20of%20Things#getanorgid

To get an Org ID see section 3.2. on that page:

An Org ID is used to associate your hubs with your organization. You will need an Org ID in order to use the
remote access feature and monitor your hubs. You can go to https://www.lab-of-things.net/ to register for your Org ID. With an Org ID you’ll be able to use the remote monitoring feature on our Remote Management Portal, which lets you view the statuses of your deployed hubs.

Danny
Jul 28, 2014 at 11:37 PM

Ok, got the orgid = agmedia

Jul 28, 2014 at 11:38 PM
OrgId = agmedia
Jul 29, 2014 at 12:52 AM

Can I run the x64 stuff or am I going to have a problem with that? I opened Core and upgraded to 2013.

Jul 29, 2014 at 1:26 AM

What version of IE should I use, I am getting what appear to be some compatibility issues in viewing the Hub apps interfaces. Running 11.

Coordinator
Jul 29, 2014 at 1:55 AM
IE 11 should work. Can you attach a screenshot of what you're seeing?
Thanks


Coordinator
Jul 29, 2014 at 1:59 AM
RobReno wrote:
Can I run the x64 stuff or am I going to have a problem with that? I opened Core and upgraded to 2013.
For the webcam driver and the camera viewer app VS 2013 will ask you to upgrade some C++ dependencies. Go ahead and upgrade.
Jul 29, 2014 at 3:27 PM

Here are some screen shots. Will upload private youtube of the “start debugging” errors shortly.

Jul 29, 2014 at 6:04 PM

Started Platform from script: startplatform

From SurfacePro 2 opened: http://www.lab-of-things.net:51431/reno/GuiWeb/index.html

Able to view Settings and added user (myself) successfully.

Trying to install a my webcam on laptop but not sure if I am doing it right.

Dashboard -> Add Devices and I see a device which is my webcam listed “HP TrueVision HD”, but when I click it I really quickly flash through the device set screen and end up on a blank white page with no user controls.

I can barely read the error message, something about “failed json URL … driver .. can read rest

Jul 30, 2014 at 3:21 PM
Edited Jul 30, 2014 at 3:22 PM
Here is my latest attempt:
  1. Forked and Downloaded labofthings.
  2. Opened VS2013 as Admin and successfully compiled solution.
  3. Opened Dashboard.
  4. Plugged in USB Live Cam.
  5. Added Device (USB Live Cam).
  6. Added Camera Application.
  7. Was able to view via Hub the Live Cam video.
Note: I have not been able to get Dashboard to recognize the Integrated "HP TrueVision HD" cam as it throws a json error when redirecting to the final setup device page. Page is blank white and frozen. Was so far able to get the following from the Hub browser:

<html><script type='text/javascript'>function redirect(url) { document.location.href=url;} </script><script type='text/javascript'> redirect('redirect?stoken=acH%2bG6o8SHE%2fwMCaLXRK%2bt3oII4zS9b9EVwgI7h6I5EKV9YLZcqTctWqH8UxOh9ANIU%2bjm%2fGK7%2byYD0P8hUiOidXf%2b%2bWySa4DMF5eFroT8QLokusLKXim%2byX0hFoBBFXFCmTeJ6eH0W5DhoxLgvU%2bxH5f3uw%2bx9CDrDi52OUbIHCpHKdr0kovQCysvG2Cbh%2b2tuKnhgTi9PfCmTzgueRpdXh0qRq4WtRbjpqkkV2L84%3d&appctx=http://localhost:51430/RReno/GuiWeb/AddDeviceFinalDeviceSetup.html?DeviceId=HP TrueVision HD
&action=login&scheme=systemlow '); </script></html>

Is there a way I could get a developer to look at the problem?