This project is read-only.

Light App not working

May 7, 2014 at 3:54 PM
So when I try to run the Lights App, it comes back with "Service not ready, retrying".

I have compiled the app, and double checked that the dll is there.

Any ideas why this is happening?
May 7, 2014 at 5:45 PM
Hi

That message is displayed when the platform is trying to start the service (the part of the application that runs on the hub). Sometimes it takes a little while for the service to start up. Two questions: Have you tried waiting for a little bit (minute or so)? Can you provide the associated homeos.log file (in output\data\platform folder) so I can look if there are any useful error messages being printed out?

Are you able to run other applications? (e.g. sensor?)

A.J.


May 7, 2014 at 6:19 PM
Edited May 7, 2014 at 6:21 PM
Hi A.J.,

I have tried waiting for a while with no success. I was able to run Sensor.

My log can be found at the following location: log
May 7, 2014 at 9:10 PM
Hi

Okay, my next suggestion would be to run platform in the debugger and find the place where it starts the lights application. (Sorry not in front of the code right now but can dig into it if you can't find it).

Also double check that the lights application is in output\binaries\Pipeline\AddIns (look for a directory called Switch which is the behind the scenes name of Lights).

A.J.